summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-06-08 12:58:16 +0300
committerModestas Vainius <modestas@vainius.eu>2009-06-08 12:58:16 +0300
commit48f1d3414f3eb11bca9fd5abd0140232a872c999 (patch)
tree34bc9977efaa4f7bafb4efd313352c7a1073f387 /Debian/Debhelper/Buildsystem
parent59c01ce2d0a90b116bb0ea5ffbdcc939b49fbbf8 (diff)
Use the term "build step" instead of "build action" everywhere in the source.
I'm going to use this new term in documentation. I have never liked "action" in this context, just couldn't think of anything better.
Diffstat (limited to 'Debian/Debhelper/Buildsystem')
-rw-r--r--Debian/Debhelper/Buildsystem/autoconf.pm4
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm4
-rw-r--r--Debian/Debhelper/Buildsystem/makefile.pm4
-rw-r--r--Debian/Debhelper/Buildsystem/perl_build.pm4
-rw-r--r--Debian/Debhelper/Buildsystem/perl_makemaker.pm4
5 files changed, 10 insertions, 10 deletions
diff --git a/Debian/Debhelper/Buildsystem/autoconf.pm b/Debian/Debhelper/Buildsystem/autoconf.pm
index fcdc2567..d7018bb2 100644
--- a/Debian/Debhelper/Buildsystem/autoconf.pm
+++ b/Debian/Debhelper/Buildsystem/autoconf.pm
@@ -17,10 +17,10 @@ sub DESCRIPTION {
sub check_auto_buildable {
my $this=shift;
- my ($action)=@_;
+ my ($step)=@_;
# Handle configure; the rest - next class
- if ($action eq "configure") {
+ if ($step eq "configure") {
return -x "configure";
}
return 0;
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index 8bdbabbb..bb038727 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -16,9 +16,9 @@ sub DESCRIPTION {
sub check_auto_buildable {
my $this=shift;
- my ($action)=@_;
+ my ($step)=@_;
my $ret = -e "CMakeLists.txt";
- $ret &&= $this->SUPER::check_auto_buildable(@_) if $action ne "configure";
+ $ret &&= $this->SUPER::check_auto_buildable(@_) if $step ne "configure";
return $ret;
}
diff --git a/Debian/Debhelper/Buildsystem/makefile.pm b/Debian/Debhelper/Buildsystem/makefile.pm
index 244ef30d..4f15152b 100644
--- a/Debian/Debhelper/Buildsystem/makefile.pm
+++ b/Debian/Debhelper/Buildsystem/makefile.pm
@@ -55,10 +55,10 @@ sub new {
sub check_auto_buildable {
my $this=shift;
- my ($action) = @_;
+ my ($step) = @_;
# Handles build, test, install, clean; configure - next class
- if (grep /^\Q$action\E$/, qw{build test install clean}) {
+ if (grep /^\Q$step\E$/, qw{build test install clean}) {
# This is always called in the source directory, but generally
# Makefiles are created (or live) in the the build directory.
return -e $this->get_buildpath("Makefile") ||
diff --git a/Debian/Debhelper/Buildsystem/perl_build.pm b/Debian/Debhelper/Buildsystem/perl_build.pm
index ce69f4ce..929d9e90 100644
--- a/Debian/Debhelper/Buildsystem/perl_build.pm
+++ b/Debian/Debhelper/Buildsystem/perl_build.pm
@@ -15,11 +15,11 @@ sub DESCRIPTION {
}
sub check_auto_buildable {
- my ($this, $action) = @_;
+ my ($this, $step) = @_;
# Handles everything
my $ret = -e "Build.PL";
- if ($action ne "configure") {
+ if ($step ne "configure") {
$ret &&= -e "Build";
}
return $ret;
diff --git a/Debian/Debhelper/Buildsystem/perl_makemaker.pm b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
index 46dda4f8..36586e43 100644
--- a/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+++ b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
@@ -16,10 +16,10 @@ sub DESCRIPTION {
sub check_auto_buildable {
my $this=shift;
- my ($action)=@_;
+ my ($step)=@_;
# Handles configure, install; the rest - next class
- if ($action eq "install" || $action eq "configure") {
+ if ($step eq "install" || $step eq "configure") {
return -e "Makefile.PL";
}
else {