summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-11-18 14:28:47 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-11-18 14:28:47 -0500
commita81dd8b003e5152bddeccc0c92f40c003890cbdc (patch)
treee982dde2413db24966a9bf3cc7089810a388ad18 /Debian/Debhelper/Buildsystem
parent84d4d291cbaf624cb9f91582a696ef6cb6a4e6ca (diff)
comment munging
Diffstat (limited to 'Debian/Debhelper/Buildsystem')
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm3
-rw-r--r--Debian/Debhelper/Buildsystem/perl_makemaker.pm6
2 files changed, 3 insertions, 6 deletions
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index 3eddc74f..ee90c1f9 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -18,6 +18,9 @@ sub check_auto_buildable {
my ($step)=@_;
if (-e $this->get_sourcepath("CMakeLists.txt")) {
my $ret = $this->SUPER::check_auto_buildable(@_);
+ # Existence of CMakeCache.txt indicates cmake has already
+ # been used by a prior build step, so should be used
+ # instead of the parent makefile class.
$ret++ if ($ret && -e $this->get_buildpath("CMakeCache.txt"));
return $ret > 0 ? $ret : 1;
}
diff --git a/Debian/Debhelper/Buildsystem/perl_makemaker.pm b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
index 473a3a7e..b2500ab7 100644
--- a/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+++ b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
@@ -23,12 +23,6 @@ sub check_auto_buildable {
return 1;
}
else {
- # This is backwards compatible (with << 7.3) until build, test and
- # clean steps are not reimplemented in the backwards compatibility
- # breaking way. However, this is absolutely necessary for
- # enforce_in_source_building() to work in corner cases in build,
- # test and clean steps as the next class (makefile) does not
- # enforce it.
return $this->SUPER::check_auto_buildable(@_);
}
}