summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2010-07-25 13:40:39 -0400
committerJoey Hess <joey@kitenet.net>2010-07-25 13:40:39 -0400
commit865e6266a5eaae81004bf530bc23da1c3fdc10b1 (patch)
tree5aa063427dedd8cbc9406c6cf1e352268a4bf51f /Debian/Debhelper/Buildsystem
parenteb9464fb4bbea788f2703a9bb3314dcd9fe2e0d5 (diff)
python_distutils: Pass --force to setup.py build, to ensure that when python-dbg is run it does not win and result in scripts having it in the shebang line. Closes: #589759
Diffstat (limited to 'Debian/Debhelper/Buildsystem')
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm4
1 files changed, 3 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 70307b0f..5115a8ae 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -163,7 +163,9 @@ sub setup_py {
sub build {
my $this=shift;
- $this->setup_py("build", @_);
+ $this->setup_py("build",
+ "--force",
+ @_);
}
sub install {