summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-11-16 20:40:26 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-11-16 20:40:26 -0500
commit97bda8bb14f0f314a5fa0b568e65443de3ab4f89 (patch)
treeafebe3aead0f80b144a207dba3407944bf4c8a37 /Debian/Debhelper/Buildsystem
parentd65d3ecd4416de92c1a9471ed9587395aa5c15ca (diff)
Enable verbose ctest output on test failure
When test fails, enable verbose ctest output. This allows to get more details on a test failure from the build logs. Auto-select cmake in further steps only if cmake was run in configure step. CMake writes CMakeCache.txt to build directory when it is run. Depend on the presence of this file for auto-selection in build, test, install and clean steps. Signed-off-by: Modestas Vainius <modestas@vainius.eu>
Diffstat (limited to 'Debian/Debhelper/Buildsystem')
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm5
1 files changed, 4 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index 645c8c03..03e6ade5 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -17,7 +17,10 @@ sub check_auto_buildable {
my $this=shift;
my ($step)=@_;
my $ret = -e $this->get_sourcepath("CMakeLists.txt");
- $ret &&= $this->SUPER::check_auto_buildable(@_) if $step ne "configure";
+ if ($step ne "configure") {
+ $ret &&= -e $this->get_buildpath("CMakeCache.txt") &&
+ $this->SUPER::check_auto_buildable(@_);
+ }
return $ret;
}