summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Dh_Buildsystems.pm
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-06-08 21:32:27 +0300
committerModestas Vainius <modestas@vainius.eu>2009-06-08 23:01:02 +0300
commitf897611a77726655aea258af0c4d52a8ce759ebc (patch)
tree7e89d87f0a98706d4b7864eb571d341e1ade7542 /Debian/Debhelper/Dh_Buildsystems.pm
parent9c95d2ea547f3566f1bf8b67c08da57845325341 (diff)
Improvements in DH_OPTIONS handling and DH_AUTO_OPTIONS envvar support.
* DH_AUTO_OPTIONS is like existing DH_OPTIONS, just only for dh_auto stuff. This also avoids "explosion" of separate DH_AUTO_* environment variables (i.e. exports in debian/rules) and encourages usage of dh_auto command line option names. DH_AUTO_OPTIONS is passed via "extra_args" to Dh_Lib::init() (API addition). * When splitting options from DH_OPTIONS and its flavours, allow arguments to include whitespaces if they are escaped with backslash (\) (see split_options_string()). Document this in debhelper.pod. * Short option for --buildsystem is -c (aka class). * Provide API to cancel option specs from default debhelper options. It will be used in the feature.
Diffstat (limited to 'Debian/Debhelper/Dh_Buildsystems.pm')
-rw-r--r--Debian/Debhelper/Dh_Buildsystems.pm18
1 files changed, 7 insertions, 11 deletions
diff --git a/Debian/Debhelper/Dh_Buildsystems.pm b/Debian/Debhelper/Dh_Buildsystems.pm
index 80b66887..be29ac5c 100644
--- a/Debian/Debhelper/Dh_Buildsystems.pm
+++ b/Debian/Debhelper/Dh_Buildsystems.pm
@@ -65,27 +65,23 @@ sub load_buildsystem {
sub buildsystems_init {
my %args=@_;
- # TODO: Not documented in the manual pages yet.
- # Initialize options from environment variables
- if (exists $ENV{DH_AUTO_BUILDDIRECTORY}) {
- $opt_builddir = $ENV{DH_AUTO_BUILDDIRECTORY};
- }
- if (exists $ENV{DH_AUTO_BUILDSYSTEM}) {
- $opt_buildsys = $ENV{DH_AUTO_BUILDSYSTEM};
- }
-
# Available command line options
my %options = (
"b:s" => \$opt_builddir,
"builddirectory:s" => \$opt_builddir,
- "m=s" => \$opt_buildsys,
+ "c=s" => \$opt_buildsys,
"buildsystem=s" => \$opt_buildsys,
"l" => \$opt_list,
"--list" => \$opt_list,
);
- map { $args{options}{$_} = $options{$_} } keys(%options);
+ $args{options}{$_} = $options{$_} foreach keys(%options);
+
+ # Pass options from the DH_AUTO_OPTIONS environment variable
+ if (defined $ENV{DH_AUTO_OPTIONS}) {
+ $args{extra_args} = $ENV{DH_AUTO_OPTIONS};
+ }
Debian::Debhelper::Dh_Lib::init(%args);
}