summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Dh_Getopt.pm
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-06-12 00:29:04 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-06-12 00:29:04 -0400
commite71d6861d8a40562512b934a70ebde0bb1b2518b (patch)
treef1877396bcbbfe6a53b3ec236a0e33449a7a5ccb /Debian/Debhelper/Dh_Getopt.pm
parent017aab3338870df4b068ce0b5f597cf1650099ac (diff)
parent69e898ae9f320e1bf812622e98c92f6949853b6e (diff)
Merge branch 'master' into buildsystems
Conflicts: Debian/Debhelper/Dh_Getopt.pm debian/changelog
Diffstat (limited to 'Debian/Debhelper/Dh_Getopt.pm')
-rw-r--r--Debian/Debhelper/Dh_Getopt.pm10
1 files changed, 5 insertions, 5 deletions
diff --git a/Debian/Debhelper/Dh_Getopt.pm b/Debian/Debhelper/Dh_Getopt.pm
index bddc06b8..2a5aa6c2 100644
--- a/Debian/Debhelper/Dh_Getopt.pm
+++ b/Debian/Debhelper/Dh_Getopt.pm
@@ -173,11 +173,11 @@ sub parseopts {
# dh through an override target to a command.
if (defined $ENV{DH_INTERNAL_OPTIONS}) {
@ARGV_extra=split_options_string($ENV{DH_INTERNAL_OPTIONS});
- my $ret=getoptions(\@ARGV_extra, $options);
- if (!$ret) {
- warning("warning: unknown options will be a fatal error in a future debhelper release");
- #error("unknown option; aborting");
- }
+ # Unknown options will be silently ignored.
+ my $oldwarn=$SIG{__WARN__};
+ $SIG{__WARN__}=sub {};
+ getoptions(\@ARGV_extra, $options);
+ $SIG{__WARN__}=$oldwarn;
# Avoid forcing acting on packages specified in
# DH_INTERNAL_OPTIONS. This way, -p can be specified