summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Dh_Lib.pm
diff options
context:
space:
mode:
authorjoey <joey>2001-01-28 09:52:41 +0000
committerjoey <joey>2001-01-28 09:52:41 +0000
commitc89efb0352c6c4af78bc8d5ebbe7cb3846ff89f3 (patch)
tree314535c835fa7d8bb8e13967e9ec801fe5fbb3b2 /Debian/Debhelper/Dh_Lib.pm
parent454aea6d19ef8a973b6467c594691be4ba937b1c (diff)
r412: * Bah, reverted that last change. It isn't useful because
dpkg-buildpackage reads the real control file and gets confused.
Diffstat (limited to 'Debian/Debhelper/Dh_Lib.pm')
-rw-r--r--Debian/Debhelper/Dh_Lib.pm8
1 files changed, 2 insertions, 6 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 4140642b..ef924b67 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -383,10 +383,6 @@ sub filearray {
}
}
-sub getcontrol {
- return $ENV{DH_CONTROL} || 'debian/control';
-}
-
# Returns a list of packages in the control file.
# Must pass "arch" or "indep" or "same" to specify arch-dependant or
# -independant or same arch packages. If nothing is specified, returns all
@@ -405,8 +401,8 @@ sub GetPackages {
my $package="";
my $arch="";
my @list=();
- open (CONTROL, getcontrol()) ||
- error("cannot read ".getcontrol().": $!\n");
+ open (CONTROL, 'debian/control') ||
+ error("cannot read debian/control: $!\n");
while (<CONTROL>) {
chomp;
s/\s+$//;