summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Dh_Lib.pm
diff options
context:
space:
mode:
authorjoey <joey>2002-06-20 01:31:47 +0000
committerjoey <joey>2002-06-20 01:31:47 +0000
commit3c36c2532c3907f0a315d9010654176e8e9fc319 (patch)
tree70b62139d1778f1d91e390401f5c7499c0ff622e /Debian/Debhelper/Dh_Lib.pm
parent89e2b47d7d18354a701733b401e613ed84acd8ee (diff)
r532: * Added --mainpackage= option, of use in some kernel modules packages.
* dh_gencontrol only needs to pass -p to dpkg-gencontrol if there is more than one package in debian/control. This makes it a bit more flexible in some cases.
Diffstat (limited to 'Debian/Debhelper/Dh_Lib.pm')
-rw-r--r--Debian/Debhelper/Dh_Lib.pm9
1 files changed, 6 insertions, 3 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index d1c67b53..f22e8171 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -72,10 +72,13 @@ sub init {
$dh{NO_ACT}=1;
}
- # Get the name of the main binary package (first one listed in
- # debian/control).
my @allpackages=GetPackages();
- $dh{MAINPACKAGE}=$allpackages[0];
+ # Get the name of the main binary package (first one listed in
+ # debian/control). Only if the main package was not set on the
+ # command line.
+ if (! exists $dh{MAINPACKAGE} || ! defined $dh{MAINPACKAGE}) {
+ $dh{MAINPACKAGE}=$allpackages[0];
+ }
# Check if packages to build have been specified, if not, fall back to
# the default, doing them all.