summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Dh_Lib.pm
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-05-11 14:53:58 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-05-11 14:53:58 -0400
commite5fbf2c660a99ab58837f1b9829f8faac7d8fc77 (patch)
tree1e22d3ecf3c5b7e5817fbdae85b15edbcfd401f5 /Debian/Debhelper/Dh_Lib.pm
parent01e9d76b1d45249f24e52a76fcbefa2a68db2ac1 (diff)
parent4e6b4536d7611a303b4e57de932dce5bd07ee93f (diff)
Merge branch 'master' into buildsystems
Conflicts: debian/changelog dh_auto_configure
Diffstat (limited to 'Debian/Debhelper/Dh_Lib.pm')
-rw-r--r--Debian/Debhelper/Dh_Lib.pm1
1 files changed, 1 insertions, 0 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index f0ad505b..c80389d7 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -301,6 +301,7 @@ sub dirname {
# Try the file..
open (COMPAT_IN, "debian/compat") || error "debian/compat: $!";
my $l=<COMPAT_IN>;
+ close COMPAT_IN;
if (! defined $l || ! length $l) {
warning("debian/compat is empty, assuming level $c");
}