summaryrefslogtreecommitdiff
path: root/Debian/Debhelper
diff options
context:
space:
mode:
authorjoey <joey>2001-11-17 21:01:33 +0000
committerjoey <joey>2001-11-17 21:01:33 +0000
commit2d76f9e8cf76146e7b24ac4232918f584cfb8a16 (patch)
tree0d68cc6e0a8f3be71b0f3e45d4c5177a564fa189 /Debian/Debhelper
parentda77014a9f5c7467c47e527e70a7fb8c433595c7 (diff)
r495: * dh_undocumented: check for existing uncompressed man pages. Closes: #87972
* Optimized dh_installdeb conffile finding. Closes: #119035 * dh_installdeb: changed the #!/bin/sh -e to set -e on a new line. Whether this additional bloat is worth it to make it easier for people to sh -x a script by hand is debatable either way, I guess. Closes: #119046 * Added a check for duplicated package stanzas in debian/control, Closes: #118805
Diffstat (limited to 'Debian/Debhelper')
-rw-r--r--Debian/Debhelper/Dh_Lib.pm9
1 files changed, 9 insertions, 0 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 4beaa0dc..fd3c12ec 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -412,6 +412,7 @@ sub GetPackages {
my $package="";
my $arch="";
my @list=();
+ my %seen;
open (CONTROL, 'debian/control') ||
error("cannot read debian/control: $!\n");
while (<CONTROL>) {
@@ -419,10 +420,18 @@ sub GetPackages {
s/\s+$//;
if (/^Package:\s*(.*)/) {
$package=$1;
+ # Detect duplicate package names in the same control file.
+ if (! $seen{$package}) {
+ $seen{$package}=1;
+ }
+ else {
+ error("debian/control has a duplicate entry for $package");
+ }
}
if (/^Architecture:\s*(.*)/) {
$arch=$1;
}
+
if (!$_ or eof) { # end of stanza.
if ($package &&
(($type eq 'indep' && $arch eq 'all') ||