summaryrefslogtreecommitdiff
path: root/Debian/Debhelper
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-07-19 09:34:07 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-07-19 09:34:07 +0200
commitb45b22e81de116cc497782fdb199eca19ecdd654 (patch)
tree8def040c13b2e3b9b1e0abcc5ec49a2b3b76571d /Debian/Debhelper
parentc37c455dc7130a1c8b77e4a7a4c0241be0dcafb4 (diff)
minor improvement
Diffstat (limited to 'Debian/Debhelper')
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm6
1 files changed, 3 insertions, 3 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 9468e38f..502bf24f 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -89,9 +89,9 @@ sub setup_py {
# We need to to run setup.py with the default python first
# as distutils/setuptools modifies the shebang lines of scripts.
# This ensures that #!/usr/bin/python is used and not pythonX.Y
- $this->doit_in_sourcedir("python", "setup.py", $act, @_);
- for my $python (grep(!/^$python_default/, (split ' ', `pyversions -r 2>/dev/null`))) {
- if (-x "/usr/bin/" . $python) {
+ foreach my $python ("python", grep(!/^$python_default/,
+ (split ' ', `pyversions -r 2>/dev/null`))) {
+ if (-x "/usr/bin/".$python) {
$this->doit_in_sourcedir($python, "setup.py", $act, @_);
}
}