summaryrefslogtreecommitdiff
path: root/Debian/Debhelper
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-08-27 12:03:50 -0400
committerJoey Hess <joey@kitenet.net>2012-08-27 12:03:50 -0400
commit00250d8cd20a37be362850d3ed8a652b0768455f (patch)
tree8724f97d15bee729f8abd4adaa5b28bfb6525cb1 /Debian/Debhelper
parenta597db5ca7446d2d13fa66578ae6720fcbf50459 (diff)
python distutils buildsystem: When checking if a version of python is installed, don't trust the presense of the executable, as a python2.X-minimal package may provide it while not having distutils installed. Closes: #683557
python hate increasing..
Diffstat (limited to 'Debian/Debhelper')
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm2
1 files changed, 1 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 4795b7c3..81cff3c9 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -155,7 +155,7 @@ sub setup_py {
}
foreach my $python (@python_dbg, @python_requested) {
- if (-x "/usr/bin/".$python) {
+ if (-f "/usr/lib/$python/distutils/__init__.py") {
# To allow backports of debhelper we don't pass
# --install-layout=deb to 'setup.py install` for
# those Python versions where the option is