summaryrefslogtreecommitdiff
path: root/Debian/Debhelper
diff options
context:
space:
mode:
authorSteve Langasek <steve.langasek@linaro.org>2011-03-10 22:28:24 -0800
committerJoey Hess <joey@kitenet.net>2011-03-12 13:59:45 -0400
commit859b245e93028ff72ae9f19dc5f49af7406e7ac8 (patch)
tree2c49d8c545867948bf6bae2f32488bbe22ee7c66 /Debian/Debhelper
parent409480cf2a740ca9faa62d73e0aab110390cfcb4 (diff)
Add support for multiarch.
Open compat level 9, which incompatibly changes dh_auto_configure behavior to set --libdir and --libexecdir to the multiarch directory path. This requires dpkg-dev 1.16.0 (not yet released) for the multiarch directory variable, so bump the dependency to this version. Also set a new substvar, misc:Pre-Depends, to multiarch-support, a virtual package provided by versions of eglibc that support the multiarch library paths at runtime; this needs to be a pre-dependency to ensure unpacked but not-yet-configured libraries can still be found during upgrades, so library packages converting to multiarch (i.e., switching to compat 9) will need to add this substitution by hand to debian/control.
Diffstat (limited to 'Debian/Debhelper')
-rw-r--r--Debian/Debhelper/Buildsystem/autoconf.pm9
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
2 files changed, 8 insertions, 3 deletions
diff --git a/Debian/Debhelper/Buildsystem/autoconf.pm b/Debian/Debhelper/Buildsystem/autoconf.pm
index d7b0bed2..f0948f36 100644
--- a/Debian/Debhelper/Buildsystem/autoconf.pm
+++ b/Debian/Debhelper/Buildsystem/autoconf.pm
@@ -7,7 +7,7 @@
package Debian::Debhelper::Buildsystem::autoconf;
use strict;
-use Debian::Debhelper::Dh_Lib qw(dpkg_architecture_value sourcepackage);
+use Debian::Debhelper::Dh_Lib qw(dpkg_architecture_value sourcepackage compat);
use base 'Debian::Debhelper::Buildsystem::makefile';
sub DESCRIPTION {
@@ -37,7 +37,12 @@ sub configure {
push @opts, "--infodir=\${prefix}/share/info";
push @opts, "--sysconfdir=/etc";
push @opts, "--localstatedir=/var";
- push @opts, "--libexecdir=\${prefix}/lib/" . sourcepackage();
+ if (! compat(8)) {
+ push @opts, "--libdir=\${prefix}/lib/" . dpkg_architecture_value("DEB_HOST_MULTIARCH");
+ push @opts, "--libexecdir=\${prefix}/lib/" . dpkg_architecture_value("DEB_HOST_MULTIARCH") . "/" . sourcepackage();
+ } else {
+ push @opts, "--libexecdir=\${prefix}/lib/" . sourcepackage();
+ }
push @opts, "--disable-maintainer-mode";
push @opts, "--disable-dependency-tracking";
# Provide --host only if different from --build, as recommended in
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 01777210..dcba4d24 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -20,7 +20,7 @@ use vars qw(@ISA @EXPORT %dh);
&is_make_jobserver_unavailable &clean_jobserver_makeflags
&cross_command);
-my $max_compat=8;
+my $max_compat=9;
sub init {
my %params=@_;