summaryrefslogtreecommitdiff
path: root/Debian
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-05-14 14:25:07 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-05-14 14:25:07 -0400
commit692ac0f0d2b7acc570cd6a5f8cac848109daf026 (patch)
tree595da5b949e88f2e05c44cf755f007dc5bdc2465 /Debian
parent9803d8bb635132458142416d32273c9c754b2aca (diff)
parent61aa7954cd6c8620ca99a0d7895aa5a6f59d37e0 (diff)
Merge branch 'master' into buildsystems
Conflicts: debian/changelog dh_auto_configure
Diffstat (limited to 'Debian')
-rw-r--r--Debian/Debhelper/Buildsystem/perl_makemaker.pm2
-rw-r--r--Debian/Debhelper/Dh_Lib.pm23
2 files changed, 21 insertions, 4 deletions
diff --git a/Debian/Debhelper/Buildsystem/perl_makemaker.pm b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
index c62041fe..a7bb5cc9 100644
--- a/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+++ b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
@@ -40,7 +40,7 @@ sub configure {
# # always return the default without waiting for user input.
$ENV{PERL_MM_USE_DEFAULT}=1;
doit("perl", "Makefile.PL", "INSTALLDIRS=vendor",
- "create_packlist=0", "--skipdeps",
+ "create_packlist=0",
@_);
}
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index c80389d7..28a90f7b 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -347,12 +347,15 @@ sub tmpdir {
#
# It tries several filenames:
# * debian/package.filename.buildarch
+# * debian/package.filename.buildos
# * debian/package.filename
-# * debian/file (if the package is the main package)
-# If --name was specified then tonly the first two are tried, and they must
-# have the name after the pacage name:
+# * debian/filename (if the package is the main package)
+# If --name was specified then the files
+# must have the name after the package name:
# * debian/package.name.filename.buildarch
+# * debian/package.name.filename.buildos
# * debian/package.name.filename
+# * debian/name.filename (if the package is the main package)
sub pkgfile {
my $package=shift;
my $filename=shift;
@@ -362,6 +365,7 @@ sub pkgfile {
}
my @try=("debian/$package.$filename.".buildarch(),
+ "debian/$package.$filename.".buildos(),
"debian/$package.$filename");
if ($package eq $dh{MAINPACKAGE}) {
push @try, "debian/$filename";
@@ -621,6 +625,19 @@ sub dpkg_architecture_value {
}
}
+# Returns the build OS. (Memoized)
+{
+ my $os;
+
+ sub buildos {
+ return $os if defined $os;
+
+ $os=`dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null` || error("dpkg-architecture failed");
+ chomp $os;
+ return $os;
+ }
+}
+
# Passed an arch and a list of arches to match against, returns true if matched
sub samearch {
my $arch=shift;