summaryrefslogtreecommitdiff
path: root/Debian
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-08-15 20:14:44 +0200
committerJoey Hess <joey@kitenet.net>2013-08-15 20:21:26 +0200
commit71d06996481c6187b016c3b14b7e9faaf8adc432 (patch)
treecbdb8882f31a7348e2b039c2bb3ca3aae171ca76 /Debian
parentfeb76f76e099df14be6ca5c33baf91d0a4f307a9 (diff)
dh_install, dh_installdocs, dh_clean: Fix uses of find -exec which cause it to ignore exit status of the commands run.
Diffstat (limited to 'Debian')
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm2
1 files changed, 1 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 4795b7c3..c3d58cc0 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -204,7 +204,7 @@ sub clean {
}
# The setup.py might import files, leading to python creating pyc
# files.
- $this->doit_in_sourcedir('find', '.', '-name', '*.pyc', '-exec', 'rm', '{}', ';');
+ $this->doit_in_sourcedir('find', '.', '-name', '*.pyc', '-exec', 'rm', '{}', '+');
}
1