summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-02-09 17:38:42 -0400
committerJoey Hess <joey@kitenet.net>2013-02-09 17:38:42 -0400
commite9fe3cee83cdcc4df978fb1761009dfc124add92 (patch)
treef2d4ecd5770787bfff5290dbabc8d9a755c35b65 /Makefile
parent7765a25a48492d2d971c836c8e609422c540d721 (diff)
Avoid find -perm +mode breakage caused by findutils 4.5.11, by instead using -perm /mode. Closes: #700200
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index fcaa4fdc..f9bb33d9 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
# List of files of dh_* commands. Sorted for debhelper man page.
-COMMANDS=$(shell find . -maxdepth 1 -type f -perm +100 -name "dh_*" -printf "%f\n" | sort)
+COMMANDS=$(shell find . -maxdepth 1 -type f -perm /100 -name "dh_*" -printf "%f\n" | sort)
# Find deprecated commands by looking at their synopsis.
DEPRECATED=$(shell egrep -l '^dh_.* - .*deprecated' $(COMMANDS))
@@ -50,7 +50,7 @@ LANGS=
endif
build: version debhelper.7
- find . -maxdepth 1 -type f -perm +100 -name "dh*" \
+ find . -maxdepth 1 -type f -perm /100 -name "dh*" \
-exec $(POD2MAN) {} {}.1 \;
ifneq ($(USE_NLS),no)
po4a --previous -L UTF-8 man/po4a/po4a.cfg