summaryrefslogtreecommitdiff
path: root/debhelper.pod
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-01-15 14:40:21 -0400
committerJoey Hess <joey@kitenet.net>2012-01-15 14:40:21 -0400
commit22ee10a98be87ff7258e413007a568c529929b54 (patch)
tree732d84f1fc9cd7356b721bb6ffaebfd4235c077d /debhelper.pod
parent53792690d7e3e4131013bd1fdc0983bc42995685 (diff)
move build depends section into compat section
Diffstat (limited to 'debhelper.pod')
-rw-r--r--debhelper.pod24
1 files changed, 10 insertions, 14 deletions
diff --git a/debhelper.pod b/debhelper.pod
index 2a8f5de..011fb6e 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -271,6 +271,12 @@ F<debian/compat>. For example, to turn on v9 mode:
% echo 9 > debian/compat
+Your package will also need a versioned build dependency on a version of
+debhelper equal to (or greater than) the compatibility level your package
+uses. So for compatibility level 9, ensure debian/control has:
+
+ Build-Depends: debhelper (>= 9)
+
Unless otherwise indicated, all debhelper documentation assumes that you
are using the most recent compatibility level, and in most cases does not
indicate if the behavior is different in an earlier compatibility level, so
@@ -615,22 +621,12 @@ act on.
=head2 udebs
Debhelper includes support for udebs. To create a udeb with debhelper,
-add "B<Package-Type: udeb>" to the package's stanza in F<debian/control>, and
-build-depend on debhelper (>= 4.2). Debhelper will try to create udebs that
-comply with debian-installer policy, by making the generated package files
-end in F<.udeb>, not installing any documentation into a udeb, skipping over
+add "B<Package-Type: udeb>" to the package's stanza in F<debian/control>.
+Debhelper will try to create udebs that comply with debian-installer
+policy, by making the generated package files end in F<.udeb>, not
+installing any documentation into a udeb, skipping over
F<preinst>, F<postrm>, F<prerm>, and F<config> scripts, etc.
-=head2 Build depends
-
-Once your package uses debhelper to build, be sure to add
-debhelper to your Build-Depends line in F<debian/control>. You should
-build-depend on a version of debhelper equal to (or greater than) the
-debhelper compatibility level your package uses. So if your package used
-compatibility level 9:
-
- Build-Depends: debhelper (>= 9)
-
=head1 ENVIRONMENT
=over 4