summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorjoey <joey>1999-08-17 04:12:54 +0000
committerjoey <joey>1999-08-17 04:12:54 +0000
commit938b66ee19e113785e6655b1c3e73e9003e6464c (patch)
treed06bd22faa3da8940bec71ba2e34e2028b6e7764 /debian/rules
r1: Initial revision
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules42
1 files changed, 42 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..0806a4db
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,42 @@
+#!/usr/bin/make -f
+# Note that I have to refer to debhelper programs witrh ./, to make sure
+# I run the most current ones.
+
+test_files=dh_lib
+
+build:
+ ./dh_testdir $(test_files)
+
+clean:
+ ./dh_testdir $(test_files)
+ ./dh_testroot
+ ./dh_clean
+
+# Build architecture-dependent files here.
+binary-arch: build
+ # We have nothing to do by default.
+
+# Build architecture-independent files here.
+binary-indep: build
+ ./dh_testdir $(test_files)
+ ./dh_testroot
+ ./dh_clean
+
+ install -d debian/tmp/usr/bin
+ find . -perm +111 -maxdepth 1 -type f \
+ -exec install -p {} debian/tmp/usr/bin \;
+ install -d debian/tmp/usr/lib/debhelper
+ cp dh_lib debian/tmp/usr/lib/debhelper
+
+ ./dh_installdocs TODO
+ ./dh_installexamples examples/*
+# ./dh_installmenu
+ ./dh_installmanpages
+ ./dh_installchangelogs
+ ./dh_compress
+ ./dh_installdebfiles
+ ./dh_fixperms
+ ./dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary