summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-02-27 15:12:58 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-02-27 15:12:58 -0500
commitaa2e7a24dbe8dfe62b9dcc967282858cee0f6087 (patch)
treef7dace53b5d9f6923e093f47747c427458dfd81f /debian/rules
parent6c80d913e37857ae525d6ff7464cedcb01a67658 (diff)
dh: Support debian/rules calling make with -B
That is useful to avoid issues with phony implicit rules (see bug #509756). Apparently make treats the name of the Makfile as an automaticall set up target, so this causes it to try to build the Makefile even though it's up-to-date, and the implicit target makes it run 'dh debian/rules'. So, make that a no-op. (cherry picked from commit 378b377ef732119de4c2a08dcb9721500b017da1) Conflicts: debian/changelog dh
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 03db2d00..ae141867 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,4 @@
-#!/usr/bin/make -f
+#!/usr/bin/make -Bf
# If you're looking for an example debian/rules that uses debhelper, see
# the examples directory.
#
@@ -11,3 +11,5 @@
# Not intended for use by anyone except the author.
announcedir:
@echo ${HOME}/src/joeywiki/code/debhelper/news
+
+.PHONY: build