summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-04-23 20:16:52 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-04-23 20:16:52 -0400
commit6c051826f3241caa4afc982d402682101c63c7e3 (patch)
tree82c87293f10c8b7245caf07f9178aa495c7144a1 /debian/rules
parent957113afa3da5a763982c88427cf061cd19d974f (diff)
dh is now working
And debian/rules uses it. Sweet!
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules35
1 files changed, 2 insertions, 33 deletions
diff --git a/debian/rules b/debian/rules
index 9a90b2d6..5b8fd17c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,40 +2,9 @@
# Each debhelper command in this rules file has to be run using ./run,
# to ensure that the commands and libraries in the source tree are used,
# rather than the installed ones.
-
-build:
- ./run dh_auto_configure
- ./run dh_auto_build
- ./run dh_auto_test
-
-clean:
- ./run dh_testdir
- ./run dh_testroot
- ./run dh_auto_clean
- ./run dh_clean
-
-binary-indep: build
- ./run dh_testdir
- ./run dh_testroot
- ./run dh_clean -k
- ./run dh_auto_install
- ./run dh_installdocs
- ./run dh_installexamples
- ./run dh_installman
- ./run dh_installchangelogs
- ./run dh_link
- ./run dh_compress
- ./run dh_fixperms
- ./run dh_perl
- ./run dh_installdeb
- ./run dh_gencontrol
- ./run dh_md5sums
- ./run dh_builddeb
+%:
+ ./run dh $@
# Not intended for use by anyone except the author.
announcedir:
@echo ${HOME}/src/joeywiki/code/debhelper/news
-
-binary-arch:
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary