summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorjoey <joey>2002-01-27 06:34:33 +0000
committerjoey <joey>2002-01-27 06:34:33 +0000
commit81a1cb9028b75304b0261dfd91ba04c0e6b07bb4 (patch)
tree6d0e7665b9271a2724f36db307c267da45822f4b /debian/rules
parent26fc54549b83f4efd2db161b86159dd65da974a9 (diff)
r506: * Introduced the debian/compat file. This is the new, preferred way to say
what debhelper compatability level your package uses. It has the big advantage of being available to debhelper when you run it at the command line, as well as in debian/rules. * A new v4 feature: dh_installinit, in v4 mode, will use invoke-rc.d. This is in v4 for testing, but I may well roll it back into v3 (and earlier) once woody is released and I don't have to worry about breaking things (and, presumably, once invoke-rc.d enters policy). * Some debhelper commands will now build up a new substvars variable, ${misc:Depends}, based on things they know your package needs to depend on. For example, dh_installinit in v4 mode adds sysvinit (>= 2.80-1) to that dep list, and dh_installxfonts adds a dep on xutils. This variable should make it easier to keep track of what your package needs to depends on, supplimenting the ${shlibs:Depends} and ${perl:Depends} substvars. Hmm, this appears to be based loosely on an idea by Masato Taruishi <taru@debian.org>, filtered through a long period of mulling it over. Closes: #76352 * Use the addsubstvar function I wrote for the above in dh_perl too.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 0 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index bf37bcab..363c8c81 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,9 +14,6 @@ export PERL5LIB=.
# be sure to use the new templates from this package.
export DH_AUTOSCRIPTDIR=autoscripts
-# Use most recent compatability level.
-export DH_COMPAT=3
-
# Figure out the `current debhelper version.
VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Version: \(.*\)')