summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorjoey <joey>2005-11-14 05:28:34 +0000
committerjoey <joey>2005-11-14 05:28:34 +0000
commited789163b012f3dca4f119606f755f15efb214cc (patch)
treecd3ae72f5c4b5bffbf6c7248fb031cb8fa8290cd /debian/rules
parent10c8a1c864330c1d1036253ea44f00d15b2b0711 (diff)
r1822: releasing version 5.0.7
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 9 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index e2f39218..f0bf1880 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,6 +32,9 @@ PERLLIBDIR=$(shell perl -MConfig -e 'print $$Config{vendorlib}')
POD2MAN=pod2man -c Debhelper -r "$(VERSION)"
+# l10n to be built is determined from .po files
+LANGS=$(notdir $(basename $(wildcard man/po4a/po/*.po)))
+
version:
printf "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
Debian/Debhelper/Dh_Version.pm
@@ -43,10 +46,10 @@ build-stamp:
cat debhelper.pod | \
$(MAKEMANLIST) `find . -maxdepth 1 -type f -perm +100 -name "dh_*" | sort` | \
$(POD2MAN) --name="debhelper" --section=7 > debhelper.7
- po4a po/po4a.cfg
+ po4a man/po4a/po4a.cfg
set -e; \
- for dir in man/*; do \
- lang=`basename $$dir`; \
+ for lang in $(LANGS); do \
+ dir=man/$$lang; \
for file in $$dir/dh_*.pod; do \
prog=`basename $$file | sed 's/.pod//'`; \
$(POD2MAN) $$file $$prog.$$lang.1; \
@@ -62,7 +65,9 @@ clean:
./run dh_testdir
./run dh_testroot
./run dh_clean *.1 *.7 *-stamp Debian/Debhelper/Dh_Version.pm
- rm -rf man
+ for lang in $(LANGS); do \
+ rm -rf man/$$lang; \
+ done;
test: version test-stamp
test-stamp: