summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorjoey <joey>2000-07-19 00:33:24 +0000
committerjoey <joey>2000-07-19 00:33:24 +0000
commita7afc7fccd48b73037a32e511a219016ba9fee17 (patch)
treeae8ddff5a61ce11e724e0d79fa2d2ce8f7114a71 /debian/rules
parent23098f605ed8cb77509f34f2deb131c18b357c05 (diff)
r359: * I started work on debhelper v2 over a year ago, with a long list of
changes I hoped to get in that broke backwards compatability. That development stalled after only the most important change was made, although I did get out over 100 releases in the debhelper 2.0.x tree. In the meantime, lots of packages have switched to using v2, despite my warnings that doing so leaves packages open to being broken without notice until v2 is complete. * Therefore, I am calling v2 complete, as it is. Future non-compatabile changes will happen in v3, which will be started soon. This means that by using debhelper v2, one major thing changes: debhelper uses debian/<package> as the temporary directory for *all* packages; debian/tmp is no longer used to build binary packages out of. This is very useful for multi-binary packages, and I reccommend everyone switch to v2. * Updated example rules files to use v2 by default. * Updated all documentation to assume that v2 is being used. * Added a few notes for people still using v1. * Moved all of the README into debhelper(1).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index a677cff3..225db74c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,12 +6,16 @@
# to tell you that; just see the 25 lines of inlined perl below..
# See examples/ for some good examples.
+# Ensure that builds are self-hosting, which means I have to use the .pm
+# files in this package, not any that may be on the system.
+export PERL5LIB=.
+
# If any automatic script generation is done in building this package,
# be sure to use the new templates from this package.
export DH_AUTOSCRIPTDIR=autoscripts
# Living dangerously :-)
-export DH_COMPAT=2
+export DH_COMPAT=3
# Figure out the current debhelper version.
VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Version: \(.*\)')