summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorjoey <joey>2003-03-03 21:30:37 +0000
committerjoey <joey>2003-03-03 21:30:37 +0000
commit3aa6fbb20465d16cf23e1607b078ed3cedf95ebe (patch)
tree1734631097fb2beec39ee25db51706f2a05f385a /debian/rules
parent52eff396c8a1595a3d2940ac70bf3cc2b9cec798 (diff)
r576: * Rename debhelper.1 to debhelper.7.
* Typo, Closes: #183267
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index ab30a3e5..e53eea42 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,7 +23,7 @@ build: test build-stamp
build-stamp:
# Generate the main man page. All the perl cruft is to get a list
# of debhelper commands with short descriptions into the man page.
- pod2man -c Debhelper -r "$(VERSION)" debhelper.pod | \
+ pod2man --section=7 -c Debhelper -r "$(VERSION)" debhelper.pod | \
perl -e ' \
undef $$/; \
foreach (@ARGV) { \
@@ -39,7 +39,7 @@ build-stamp:
s/#LIST#/$$collect/; \
print; \
}; \
- }' `find . -type f -perm +1 -maxdepth 1 -name "dh_*" | sort` > debhelper.1
+ }' `find . -type f -perm +1 -maxdepth 1 -name "dh_*" | sort` > debhelper.7
# Turn all executables into man pages.
find . -type f -perm +1 -maxdepth 1 -name "dh_*" \
-exec pod2man -c Debhelper -r "$(VERSION)" {} {}.1 \;
@@ -74,7 +74,7 @@ binary-indep: build
./dh_install autoscripts usr/share/debhelper
./dh_installdocs doc/*
./dh_installexamples examples/*
- ./dh_installman *.1
+ ./dh_installman *.1 *.7
./dh_installchangelogs
./dh_shlibdeps
./dh_link