summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorjoey <joey>1999-08-17 05:49:18 +0000
committerjoey <joey>1999-08-17 05:49:18 +0000
commite4d49e6d0b1a65bc9f2dbc43e39516bb16fc358c (patch)
treebc21c3e1986e0a9c6b55283fa0e883f12287956f /debian/rules
parent28df295fade1a045b2fbde22001d1da524657575 (diff)
r252: * Fixed makefile commit target.
* Misc changes to make CVS dirs not be copies into package.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 8f9976f9..acd9415f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -47,9 +47,10 @@ binary-indep: link-stamp build
-exec install -p {} debian/debhelper/usr/bin \;
cp -a Dh_*.pm debian/debhelper/usr/share/debhelper
cp -a autoscripts debian/debhelper/usr/share/debhelper
+ rm -rf debian/debhelper/usr/share/debhelper/autoscripts/CVS
- ./dh_installdocs doc/*
- ./dh_installexamples examples/*
+ ./dh_installdocs `echo doc/* | grep -v CVS`
+ ./dh_installexamples `echo examples/* | grep -v CVS`
./dh_installmenu
./dh_installmanpages
./dh_installinfo
@@ -99,7 +100,7 @@ binary-indep: link-stamp build
# Install in the proper location on my ftp server and web server. Not intended
# for use by anyone except the author.
OLD_VER=$(shell perl -e '<>;<>;while(<>){last if /^ --/};<>;$$_=<>;print m/\((.*?)\)/'<debian/changelog)
-dist: link-stamp
+dist: commit link-stamp
dpkg-buildpackage -rfakeroot -tc
if [ `hostname` = 'kite' ] ; then \
cp ../debhelper_$(VERSION).tar.gz ../../public; \
@@ -127,7 +128,6 @@ commit:
cvs -Q commit -m "`dpkg-parsechangelog | grep '^ '`"
cvs -Q tag rel-$(shell dpkg-parsechangelog | grep ^Version: \
|cut -d " " -f 2 |tr '.' '-')
- $(MAKE) new
new:
# Update w/o editing.