summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2014-10-10 17:25:18 -0400
committerJoey Hess <joey@kitenet.net>2014-10-10 17:25:18 -0400
commit4d0acf739e336a6b0993665facf6308e851cea44 (patch)
tree0fb9500bbef96cf167331b6fb9ee803e2ed85333 /debian
parent4cc14d07d90780d8ccbdd291b74194355d5dc4cd (diff)
parent4402e553df5279c2f65aee8623aca504988cc508 (diff)
Merge commit '4402e553df5279c2f65aee8623aca504988cc508'
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog13
-rw-r--r--debian/control2
2 files changed, 14 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a856ece..f15f511 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,19 @@ debhelper (9.20141003) unstable; urgency=medium
-- Joey Hess <joeyh@debian.org> Fri, 03 Oct 2014 15:16:00 -0400
+debhelper (9.20140817+nmu1) UNRELEASED; urgency=medium
+
+ * Non-maintainer upload.
+ * Depend on libdpkg-perl (>= 1.17.14) for build profiles support. Note to
+ backporters: If you remove that dependency, debhelper will throw an error
+ when a binary package stanza in debian/control has the Build-Profiles
+ field.
+ * Use libdpkg-perl functionality to parse the content of the Build-Profiles
+ field, if there is one. In that case, use libdpkg-perl to evaluate whether
+ the binary package should be built or not.
+
+ -- Johannes Schauer <j.schauer@email.de> Thu, 09 Oct 2014 23:27:40 +0200
+
debhelper (9.20140817) unstable; urgency=medium
* Added Portuguese translation of the man pages, by Américo Monteiro.
diff --git a/debian/control b/debian/control
index 0786173..d54b971 100644
--- a/debian/control
+++ b/debian/control
@@ -11,7 +11,7 @@ Homepage: http://joeyh.name/code/debhelper/
Package: debhelper
Architecture: all
-Depends: ${perl:Depends}, ${misc:Depends}, file (>= 3.23), dpkg (>= 1.16.2), dpkg-dev (>= 1.17.0), binutils, po-debconf, man-db (>= 2.5.1-1)
+Depends: ${perl:Depends}, ${misc:Depends}, file (>= 3.23), dpkg (>= 1.16.2), dpkg-dev (>= 1.17.0), binutils, po-debconf, man-db (>= 2.5.1-1), libdpkg-perl (>= 1.17.14)
Suggests: dh-make
Conflicts: dpkg-cross (<< 1.18), python-support (<< 0.5.3), python-central (<< 0.5.6), automake (<< 1.11.2)
Multi-Arch: foreign