summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-08-29 20:34:00 -0400
committerJoey Hess <joey@kitenet.net>2011-08-29 20:34:00 -0400
commitd3b730cb6ff3f6a7be01591a47c04d04b203e8d8 (patch)
tree2d9bd11ab94733b7a210ce1ada72f32f57846f19 /debian
parente2920262c9374bbf0a661c53f0aaf23a6338ba14 (diff)
Remove obsolete versioned dependency on perl-base.
5.10 is in stable, which is good enough for me. (And this dependency was added for very unclear reasons in the first place.)
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/control4
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index a880106..50f8fff 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ debhelper (8.9.7) UNRELEASED; urgency=low
* dh: Don't bother running dh_shlibdebs, dh_makeshelibs, or dh_strip
for the binary target when all packages being acted on are indep.
* debhelper no longer build-depends on man-db or file, to ease bootstrapping.
+ * Remove obsolete versioned dependency on perl-base.
-- Joey Hess <joeyh@debian.org> Mon, 29 Aug 2011 20:18:01 -0400
diff --git a/debian/control b/debian/control
index 4e36ebf..ac59c97 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: debhelper
Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
-Build-Depends: po4a (>= 0.24), perl-base (>= 5.10)
+Build-Depends: po4a (>= 0.24)
Standards-Version: 3.9.2
Vcs-Git: git://git.debian.org/git/debhelper/debhelper.git
Vcs-Browser: http://git.debian.org/?p=debhelper/debhelper.git;a=summary
@@ -10,7 +10,7 @@ Homepage: http://kitenet.net/~joey/code/debhelper/
Package: debhelper
Architecture: all
-Depends: ${perl:Depends}, ${misc:Depends}, perl-base (>= 5.10), file (>= 3.23), dpkg-dev (>= 1.16.0), html2text, binutils, po-debconf, man-db (>= 2.5.1-1)
+Depends: ${perl:Depends}, ${misc:Depends}, file (>= 3.23), dpkg-dev (>= 1.16.0), html2text, binutils, po-debconf, man-db (>= 2.5.1-1)
Suggests: dh-make
Conflicts: dpkg-cross (<< 1.18), python-support (<< 0.5.3), python-central (<< 0.5.6)
Description: helper programs for debian/rules