summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorjoey <joey>2005-11-14 05:28:34 +0000
committerjoey <joey>2005-11-14 05:28:34 +0000
commited789163b012f3dca4f119606f755f15efb214cc (patch)
treecd3ae72f5c4b5bffbf6c7248fb031cb8fa8290cd /debian
parent10c8a1c864330c1d1036253ea44f00d15b2b0711 (diff)
r1822: releasing version 5.0.7
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules13
3 files changed, 20 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index f31c7fb8..13057b16 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+debhelper (5.0.7) unstable; urgency=low
+
+ * Patch from Valéry Perrin to update Frensh translation, and also update
+ the po4a stuff. Closes: #338713
+ * Fix a bad regexp in -s handling code that breaks if an architecture name,
+ such as i386-uclibc is the hyphenated version of a different arch.
+ Closes: #338555
+
+ -- Joey Hess <joeyh@debian.org> Sun, 13 Nov 2005 13:28:13 -0500
+
debhelper (5.0.6) unstable; urgency=low
* Pass --name in debhelper.pod pod2man run. Closes: #338349
diff --git a/debian/control b/debian/control
index 8f631871..5ba37778 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
Standards-Version: 3.6.2
-Build-Depends: po4a
+Build-Depends-Indep: po4a
Package: debhelper
Architecture: all
diff --git a/debian/rules b/debian/rules
index e2f39218..f0bf1880 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,6 +32,9 @@ PERLLIBDIR=$(shell perl -MConfig -e 'print $$Config{vendorlib}')
POD2MAN=pod2man -c Debhelper -r "$(VERSION)"
+# l10n to be built is determined from .po files
+LANGS=$(notdir $(basename $(wildcard man/po4a/po/*.po)))
+
version:
printf "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
Debian/Debhelper/Dh_Version.pm
@@ -43,10 +46,10 @@ build-stamp:
cat debhelper.pod | \
$(MAKEMANLIST) `find . -maxdepth 1 -type f -perm +100 -name "dh_*" | sort` | \
$(POD2MAN) --name="debhelper" --section=7 > debhelper.7
- po4a po/po4a.cfg
+ po4a man/po4a/po4a.cfg
set -e; \
- for dir in man/*; do \
- lang=`basename $$dir`; \
+ for lang in $(LANGS); do \
+ dir=man/$$lang; \
for file in $$dir/dh_*.pod; do \
prog=`basename $$file | sed 's/.pod//'`; \
$(POD2MAN) $$file $$prog.$$lang.1; \
@@ -62,7 +65,9 @@ clean:
./run dh_testdir
./run dh_testroot
./run dh_clean *.1 *.7 *-stamp Debian/Debhelper/Dh_Version.pm
- rm -rf man
+ for lang in $(LANGS); do \
+ rm -rf man/$$lang; \
+ done;
test: version test-stamp
test-stamp: