summaryrefslogtreecommitdiff
path: root/dh
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-03-06 17:56:51 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-03-06 17:56:51 -0500
commit979ec9db4fec8fc4380523db3964cf459d1a4827 (patch)
tree3b3b36189777c08b2848c83c419fdf9c25afd071 /dh
parent286f89e8dd31f967818011bd141aab46ed71a7e0 (diff)
dh: Override LC_ALL, not LANG. Closes: #517617
Diffstat (limited to 'dh')
-rwxr-xr-xdh2
1 files changed, 1 insertions, 1 deletions
diff --git a/dh b/dh
index 7cba1561..15b587d3 100755
--- a/dh
+++ b/dh
@@ -515,7 +515,7 @@ sub rules_explicit_target {
if (! $rules_parsed) {
my $processing_targets = 0;
my $not_a_target = 0;
- open(MAKE, "LANG=C make -Rrnpsf debian/rules debhelper-fail-me 2>/dev/null |");
+ open(MAKE, "LC_ALL=C make -Rrnpsf debian/rules debhelper-fail-me 2>/dev/null |");
while (<MAKE>) {
if ($processing_targets) {
if (/^# Not a target:/) {