summaryrefslogtreecommitdiff
path: root/dh
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-02-17 00:53:22 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-02-17 00:53:22 -0500
commitae4994f07656deb47ffc55b8ebd4668c158b9333 (patch)
tree4f44ba0560d88c0fa27e9f505b8cbd14f0f7b562 /dh
parent3d774a91dd355f8236c63bd81fc4dfe5fa88219d (diff)
misc minor cleanups of patch
Diffstat (limited to 'dh')
-rwxr-xr-xdh17
1 files changed, 10 insertions, 7 deletions
diff --git a/dh b/dh
index 25ca87de..8938baa4 100755
--- a/dh
+++ b/dh
@@ -504,24 +504,27 @@ sub rules_explicit_target {
# Checks if a specified target exists as an explicit target
# in debian/rules.
my $target=shift;
- my $processing_targets = 0;
- my $not_a_target = 0;
if (! $rules_parsed) {
+ my $processing_targets = 0;
+ my $not_a_target = 0;
open(MAKE, "make -Rrnpsf debian/rules debhelper-fail-me 2>/dev/null |");
while (<MAKE>) {
if ($processing_targets) {
if (/^# Not a target:/) {
$not_a_target = 1;
- } else {
- if (!$not_a_target && /^([^#:]+)::?/ && !exists $targets{$1}) {
+ }
+ else {
+ if (!$not_a_target && /^([^#:]+)::?/) {
# Target is defined.
- # NOTE: if it is a depenency of .PHONY it will be
+ # NOTE: if it is a depenency
+ # of .PHONY it will be
# defined too but that's ok.
$targets{$1} = 1;
}
- # "Not a target:" is always followed by a target name,
- # so resetting this one here is safe.
+ # "Not a target:" is always followed by
+ # a target name, so resetting this one
+ # here is safe.
$not_a_target = 0;
}
} elsif (/^# Files$/) {