summaryrefslogtreecommitdiff
path: root/dh
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-06-11 14:39:08 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-06-11 14:39:08 -0400
commit7bbc9917c046d06f7d7e8d7cad10b9e3b27a8ec9 (patch)
treea6bfa98f7ff3c043111e6523f7d7c688600f87b9 /dh
parent45d6698e772aa6990d6b27a98325cc228d7004fd (diff)
parent15a4917aa7ccfc33b99fd44ba8eb07ab431f81f7 (diff)
Merge branch 'master' into buildsystems
Conflicts: debian/changelog
Diffstat (limited to 'dh')
-rwxr-xr-xdh11
1 files changed, 7 insertions, 4 deletions
diff --git a/dh b/dh
index 701f588e..35fedbb0 100755
--- a/dh
+++ b/dh
@@ -252,7 +252,6 @@ $sequences{install} = [@{$sequences{build}}, qw{
dh_gconf
dh_icons
dh_perl
- dh_scrollkeeper
dh_usrlocal
dh_link
@@ -471,9 +470,13 @@ sub run {
# Need to handle logging for overriden commands here,
# because the actual debhelper command may not have
# been run by the rules file target.
- my %packages=map { $_ => 1 } @packages;
- map { delete $packages{$_} } @exclude;
- write_log($override_command, keys %packages);
+ # (But avoid logging for dh_clean since it removes
+ # the log earlier.)
+ if ($override_command ne 'dh_clean') {
+ my %packages=map { $_ => 1 } @packages;
+ map { delete $packages{$_} } @exclude;
+ write_log($override_command, keys %packages);
+ }
}
}
}