summaryrefslogtreecommitdiff
path: root/dh
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-07-24 12:07:28 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-07-24 12:07:28 +0200
commit86b14713761d1794c6fe6d90558db65dfba654ce (patch)
treef1bea9d4f4cd829f4c3735360a827fa0371d7058 /dh
parent798e22d35f9f9881a8b42e17e71feb0a1bfd5cdf (diff)
parentb16763070e1a04c5ca5235dc7fb9d52ff703e26b (diff)
Merge branch 'buildsystems'
Diffstat (limited to 'dh')
-rwxr-xr-xdh17
1 files changed, 16 insertions, 1 deletions
diff --git a/dh b/dh
index 35fedbb0..c34a5a02 100755
--- a/dh
+++ b/dh
@@ -179,6 +179,16 @@ sequence addons like this:
%:
dh --with quilt $@
+Here is an example of overriding where the dh_auto_* commands find
+the package's source, for a package where the source is located in a
+subdirectory. It also forces use of perl's Module::Build build system,
+which can be necessary if debhelper wrongly detects that the package
+uses MakeMaker.
+
+ #!/usr/bin/make -f
+ %:
+ dh --sourcedirectory=src --buildsystem=perl_build $@
+
=cut
# Stash this away before init modifies it.
@@ -187,6 +197,11 @@ my @ARGV_orig=@ARGV;
# python-support is enabled by default, at least for now
# (and comes first so python-central loads later and can disable it).
unshift @ARGV, "--with=python-support";
+
+# Disable complaints about unknown options for both dh and the commands
+# it runs. This is done because dh accepts and passes on options that may
+# be specific to only some debhelper commands.
+$ENV{DH_IGNORE_UNKNOWN_OPTIONS}=1;
init(options => {
"until=s" => \$dh{UNTIL},
@@ -447,7 +462,7 @@ sub run {
$override_command=$command;
# This passes the options through to commands called
# inside the target.
- $ENV{DH_INTERNAL_OPTIONS}=join(" ", @options);
+ $ENV{DH_INTERNAL_OPTIONS}=join("\x1e", @options);
$command="debian/rules";
@options="override_".$override_command;
}