summaryrefslogtreecommitdiff
path: root/dh
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-06-13 19:13:32 -0400
committerJoey Hess <joey@kitenet.net>2011-06-13 19:13:32 -0400
commit959defaccc3f49cff7c0b020b66c64a28e1ea21b (patch)
treedddc962d5ea62c966871d7fa61427d06d264b5a6 /dh
parent76bef55d5688196036574162b134860fcc3ca574 (diff)
honor empty targets
An empty explicit target in debian/rules should still be run, to run its dependencies, and allow defining empty targets in order to skip running what's nornally done by a sequence.
Diffstat (limited to 'dh')
-rwxr-xr-xdh2
1 files changed, 1 insertions, 1 deletions
diff --git a/dh b/dh
index 9c9a3432..2241c648 100755
--- a/dh
+++ b/dh
@@ -778,7 +778,7 @@ sub optimize_sequence {
foreach my $command (@_) {
my $rules_target=rules_target($command);
if (defined $rules_target &&
- ! rules_explicit_target($rules_target)) {
+ ! defined rules_explicit_target($rules_target)) {
# inline the sequence for this implicit target
$add->($_) foreach optimize_sequence(@{$sequences{$rules_target}});
}