summaryrefslogtreecommitdiff
path: root/dh
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-02-17 12:33:57 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-02-27 15:13:19 -0500
commita26b68b6c1751b338f90ce9ab0deac1c353581d9 (patch)
treece2bb8ad800a1961a28d3e59dd984cb832dd06a1 /dh
parentaa2e7a24dbe8dfe62b9dcc967282858cee0f6087 (diff)
make dh override_dh_* a no-op
This happens if the override target is completly empty. Make sees it is, and runs the implicit dh target. (cherry picked from commit 86fbd6038ee5b7222efa774751fcceedeffedfc2)
Diffstat (limited to 'dh')
-rwxr-xr-xdh13
1 files changed, 12 insertions, 1 deletions
diff --git a/dh b/dh
index 571d4b63..1ec46ba9 100755
--- a/dh
+++ b/dh
@@ -182,6 +182,15 @@ after a particular debhelper command is run.
dh_fixperms
chmod 4755 debian/foo/usr/bin/foo
+If the package's source tree might get files with names
+like build or clean in it, the rules file would not
+run targets with the same names. This issue can be worked
+around by passing -B to make.
+
+ #!/usr/bin/make -Bf
+ %:
+ dh $@
+
=cut
# Stash this away before init modifies it.
@@ -311,8 +320,10 @@ if (! @ARGV) {
error "specify a sequence to run";
}
my $sequence=shift;
-if ($sequence eq 'debian/rules') {
+if ($sequence eq 'debian/rules' ||
+ $sequence =~ /^override_dh_/) {
# make -B causes the rules file to be run as a target
+ # and support completly empty override targets
exit 0
}
elsif (! exists $sequences{$sequence}) {