summaryrefslogtreecommitdiff
path: root/dh
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-02-28 19:52:33 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-02-28 19:52:33 -0500
commitfbdf2d5a689d55c9c6df76660983533ef31a71e3 (patch)
treeeb0634f1d0c86375c3655976458810e46116ba30 /dh
parent89d07bd36d8778a5b85b24b3a53635fccb9da52b (diff)
dh: Fix make parsing to not be broken by locale settings. Closes: #517617
Diffstat (limited to 'dh')
-rwxr-xr-xdh2
1 files changed, 1 insertions, 1 deletions
diff --git a/dh b/dh
index d076919a..6c52f72e 100755
--- a/dh
+++ b/dh
@@ -506,7 +506,7 @@ sub rules_explicit_target {
if (! $rules_parsed) {
my $processing_targets = 0;
my $not_a_target = 0;
- open(MAKE, "make -Rrnpsf debian/rules debhelper-fail-me 2>/dev/null |");
+ open(MAKE, "LANG=C make -Rrnpsf debian/rules debhelper-fail-me 2>/dev/null |");
while (<MAKE>) {
if ($processing_targets) {
if (/^# Not a target:/) {