summaryrefslogtreecommitdiff
path: root/dh
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2011-06-14 19:30:59 +0100
committerJoey Hess <joey@kitenet.net>2011-06-14 16:06:40 -0400
commit6aca0eba03b03e3c898b132f5a6d005118ed6d4c (patch)
treeb15692767c9215438dea08c675976799d3fa4093 /dh
parent20fd57bb5553fb7a9767c197c854335543095f5f (diff)
dh: rules function joins array argument
Appending @_ to a string appends the array length rather than the array contents, so join with separating whitespace.
Diffstat (limited to 'dh')
-rwxr-xr-xdh2
1 files changed, 1 insertions, 1 deletions
diff --git a/dh b/dh
index 2eda3353..8d8c920a 100755
--- a/dh
+++ b/dh
@@ -801,7 +801,7 @@ sub rules_target {
}
sub rules {
- return "debian/rules ".@_;
+ return "debian/rules ".join(" ", @_);
}
{