summaryrefslogtreecommitdiff
path: root/dh
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-03-20 21:24:30 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-03-20 21:24:30 -0400
commitef2f1236c3608089934726e3769cea51fc301c17 (patch)
tree17743838c5d92eda7db84d0d04e93898a3105cb9 /dh
parentd8c894237bf0d7a4d55c5de16dda30288a1a7fd7 (diff)
pass -N into DH_INTERNAL_OPTIONS
I think I didn't do this before because it could result in parseoptions() erroring because there were no packages to act on. That is not going to be an error soon though, and it makes sense to pass in the -N excludes.
Diffstat (limited to 'dh')
-rwxr-xr-xdh9
1 files changed, 4 insertions, 5 deletions
diff --git a/dh b/dh
index 498c7cff..8639ed07 100755
--- a/dh
+++ b/dh
@@ -443,6 +443,10 @@ sub run {
my @exclude=@{shift()};
my @options=@_;
+ # If some packages are excluded, add flags
+ # to prevent them from being acted on.
+ push @options, map { "-N$_" } @exclude;
+
# Check for override targets in debian/rules and
# run them instead of running the command directly.
my $override_command;
@@ -454,11 +458,6 @@ sub run {
$command="debian/rules";
@options="override_".$override_command;
}
- else {
- # If some packages are excluded, add flags
- # to prevent them from being acted on.
- push @options, map { "-N$_" } @exclude;
- }
# 3 space indent lines the command being run up under the
# sequence name after "dh ".