summaryrefslogtreecommitdiff
path: root/dh_auto_build
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-04-23 14:22:11 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-04-23 14:22:11 -0400
commite7706c28cecffccb52f2f1e6a30a141f23fbfcf5 (patch)
treeddaff54e8ed852846e074d859104e16d43eddd31 /dh_auto_build
parentc251bfd3e5033243aaa9e50c753299bc19602733 (diff)
dh_auto_test: New program, automates running make test or make check if the Makefile has such a target.
Diffstat (limited to 'dh_auto_build')
-rwxr-xr-xdh_auto_build7
1 files changed, 4 insertions, 3 deletions
diff --git a/dh_auto_build b/dh_auto_build
index 21798cc2..2d636ea3 100755
--- a/dh_auto_build
+++ b/dh_auto_build
@@ -16,7 +16,8 @@ B<dh_auto_build> [S<I<debhelper options>>] [S<B<--> I<params>>]
=head1 DESCRIPTION
dh_auto_build is a debhelper program that tries to automatically
-build a package. If a Makefile is found, this is done by running make.
+build a package. If a Makefile is found, this is done by running make (or
+MAKE, if the environment variable is set).
If there's a setup.py, it is run to build the package.
This is intended to work for about 90% of packages. If it doesn't work,
@@ -30,7 +31,7 @@ build process manually.
=item B<--> I<params>
Pass "params" to the program that is run. These can be used to suppliment
-or override the standard parameters that dh_auto_build passes.
+or override any standard parameters that dh_auto_build passes.
=back
@@ -39,7 +40,7 @@ or override the standard parameters that dh_auto_build passes.
init();
if (-e "Makefile" || -e "makefile" || -e "GNUmakefile") {
- doit($ENV{MAKE}, @{$dh{U_PARAMS}});
+ doit(exists $ENV{MAKE} ? $ENV{MAKE} : "make", @{$dh{U_PARAMS}});
}
elsif (-e "setup.py") {
doit("python setup.py", "build", @{$dh{U_PARAMS}});