summaryrefslogtreecommitdiff
path: root/dh_auto_build
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-04-24 21:05:28 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-04-24 21:05:28 -0400
commit10d72fd2967a0220a3ca3802e3a3593a1f33515c (patch)
tree94a89adfd04189b76f1c43bfda38cd9c71d7a9e1 /dh_auto_build
parent8290ce0f62ee779b3cb7719776c1431140b91644 (diff)
dh_auto_*: Also support packages using Module::Build.
* dh_auto_*: Also support packages using Module::Build. * dh_auto_*: Fix some calls to setup.py.
Diffstat (limited to 'dh_auto_build')
-rwxr-xr-xdh_auto_build7
1 files changed, 5 insertions, 2 deletions
diff --git a/dh_auto_build b/dh_auto_build
index 2d636ea3..d35dfc63 100755
--- a/dh_auto_build
+++ b/dh_auto_build
@@ -18,7 +18,7 @@ B<dh_auto_build> [S<I<debhelper options>>] [S<B<--> I<params>>]
dh_auto_build is a debhelper program that tries to automatically
build a package. If a Makefile is found, this is done by running make (or
MAKE, if the environment variable is set).
-If there's a setup.py, it is run to build the package.
+If there's a setup.py, or Build.PL, it is run to build the package.
This is intended to work for about 90% of packages. If it doesn't work,
you're encoruaged to skip using dh_auto_build at all, and just run the
@@ -43,7 +43,10 @@ if (-e "Makefile" || -e "makefile" || -e "GNUmakefile") {
doit(exists $ENV{MAKE} ? $ENV{MAKE} : "make", @{$dh{U_PARAMS}});
}
elsif (-e "setup.py") {
- doit("python setup.py", "build", @{$dh{U_PARAMS}});
+ doit("python", "setup.py", "build", @{$dh{U_PARAMS}});
+}
+elsif (-e "Build.PL" && -e "Build") {
+ doit("perl", "Build", @{$dh{U_PARAMS}});
}
=head1 SEE ALSO