summaryrefslogtreecommitdiff
path: root/dh_auto_build
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-03-23 21:32:43 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-04-10 16:11:01 -0400
commit776abbb23a899ebba954774c8b3740706a21f72b (patch)
tree8d279923d9da02504af1da0aaaf158558ce73376 /dh_auto_build
parent51dea74baba625b8d63bbf7e19ad7e069d05ab14 (diff)
Migrates dh_auto_* commands to Dh_Buildsystems.pm
This patch switches dh_auto_* commands to use Dh_Buildsystems.pm module. Most of them became very minimal by design. Documentation has not been updated with new features yet. Signed-off-by: Modestas Vainius <modestas@vainius.eu>
Diffstat (limited to 'dh_auto_build')
-rwxr-xr-xdh_auto_build16
1 files changed, 3 insertions, 13 deletions
diff --git a/dh_auto_build b/dh_auto_build
index 75ce51cf..9cfe70ef 100755
--- a/dh_auto_build
+++ b/dh_auto_build
@@ -7,7 +7,7 @@ dh_auto_build - automatically builds a package
=cut
use strict;
-use Debian::Debhelper::Dh_Lib;
+use Debian::Debhelper::Dh_Buildsystems;
=head1 SYNOPSIS
@@ -37,18 +37,8 @@ or override any standard parameters that dh_auto_build passes.
=cut
-init();
-
-if (-e "Makefile" || -e "makefile" || -e "GNUmakefile") {
- doit(exists $ENV{MAKE} ? $ENV{MAKE} : "make", @{$dh{U_PARAMS}});
-}
-elsif (-e "setup.py") {
- doit("python", "setup.py", "build", @{$dh{U_PARAMS}});
-}
-elsif (-e "Build.PL" && -e "Build") {
- $ENV{MODULEBUILDRC} = "/dev/null";
- doit("perl", "Build", @{$dh{U_PARAMS}});
-}
+my $manager = new Debian::Debhelper::Dh_Buildsystems;
+$manager->run_dh_auto_tool();
=head1 SEE ALSO