summaryrefslogtreecommitdiff
path: root/dh_auto_clean
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-05-19 12:44:56 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-05-19 12:44:56 -0400
commitba41e534a4b79d15645d00d76269520fc6708dc0 (patch)
treea1f8c115e296d84c1c4c3f37d251c3eb10491e26 /dh_auto_clean
parentecf1bf68bddd75f3c12031295c1c286d803b47ea (diff)
dh_auto_clean: setup.py clean can create pyc files. Remove. Closes: #481899
Diffstat (limited to 'dh_auto_clean')
-rwxr-xr-xdh_auto_clean3
1 files changed, 3 insertions, 0 deletions
diff --git a/dh_auto_clean b/dh_auto_clean
index 4468fef9..13035703 100755
--- a/dh_auto_clean
+++ b/dh_auto_clean
@@ -55,6 +55,9 @@ if (-e "Makefile" || -e "makefile" || -e "GNUmakefile") {
}
elsif (-e "setup.py") {
doit("python", "setup.py", "clean", "-a", @{$dh{U_PARAMS}});
+ # The setup.py might import files, leading to python creating pyc
+ # files.
+ doit('find', '.', '-name', '*.pyc', '-exec', 'rm', '{}', ';');
}
elsif (-e "Build.PL" && -e "Build") {
doit("perl", "Build", "--allow_mb_mismatch", 1, "distclean", @{$dh{U_PARAMS}});