summaryrefslogtreecommitdiff
path: root/dh_auto_clean
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-06-18 02:11:45 +0300
committerModestas Vainius <modestas@vainius.eu>2009-06-18 02:11:45 +0300
commit962a2e10c930e3504ea1c0327be2fdf70d53023e (patch)
tree26196a25203b03818d92dd5a8ec49d2e13111675 /dh_auto_clean
parent91928482af09c4ca1092f124921d0f47613c17ba (diff)
Update dh_auto documentation.
* dh_auto.pod -> dh_auto.7 - contains general information about dh_auto, its features, build systems supported by default (the latter is injected by man/dh_auto_pod script from Debian/Debhelper/Buildsystem/*.pm PODs via placeholders (#PLACEHOLDER#)) * POD in Debian/Debhelper/Buildsystem/*.pm -> dh_auto_<buildsystem>.7 - build system specific information. * dh_auto_* -> dh_auto_*.1 - relatively shorty description of the specific dh_auto_* program and build system specific info for that step injected from Debian/Debhelper/Buildsystem/*.pm with man/dh_auto_pod script. * man/dh_auto_pod $step - generates full dh_auto_$step POD (replaces placeholders). * man/dh_auto_pod - generates full dh_auto.pod (replaces placeholders). Signed-off-by: Modestas Vainius <modestas@vainius.eu>
Diffstat (limited to 'dh_auto_clean')
-rwxr-xr-xdh_auto_clean36
1 files changed, 23 insertions, 13 deletions
diff --git a/dh_auto_clean b/dh_auto_clean
index 1b7d46cd..625675b8 100755
--- a/dh_auto_clean
+++ b/dh_auto_clean
@@ -2,7 +2,7 @@
=head1 NAME
-dh_auto_clean - automatically cleans up after a build
+dh_auto_clean - clean temporary files after building package sources
=cut
@@ -11,19 +11,21 @@ use Debian::Debhelper::Dh_Buildsystems;
=head1 SYNOPSIS
-B<dh_auto_clean> [S<I<debhelper options>>] [S<B<--> I<params>>]
+B<dh_auto_clean> [S<I<debhelper options>>] [S<I<dh_auto options>>] [S<B<--> I<params>>]
=head1 DESCRIPTION
-dh_auto_clean is a debhelper program that tries to automatically clean up
-after a package build. If there's a Makefile and it contains a "distclean",
-"realclean", or "clean" target, then this is done by running make (or MAKE,
-if the environment variable is set). If there is a setup.py or Build.PL, it
-is run to clean the package.
+dh_auto_clean is a debhelper program that is responsible for the I<clean> step
+of the L<dh_auto(7)> building process. It tries to automatically clean up after
+a package build by removing all temporary files from the build directory or
+even the build directory itself as appropriate. dh_auto_clean will fail only if
+the source build system clean routine fails. However, if the latter does not
+exist or there is nothing to clean it will exit with zero status doing nothing.
-This is intended to work for about 90% of packages. If it doesn't work, or
-tries to use the wrong clean target, you're encouraged to skip using
-dh_auto_clean at all, and just run make clean manually.
+If dh_auto_clean does not meet your needs or does not work, it is safe to
+skip/override it entirely and just run clean up manually.
+
+#DH_AUTO SHARED OPTIONS#
=head1 OPTIONS
@@ -36,6 +38,11 @@ or override the any standard parameters that dh_auto_clean passes.
=back
+=head1 SUPPORTED BUILD SYSTEMS
+
+#SUPPORTED BUILD SYSTEMS INTRO#
+#SUPPORTED BUILD SYSTEMS LIST#
+
=cut
buildsystems_init();
@@ -43,12 +50,15 @@ buildsystems_do();
=head1 SEE ALSO
+L<dh_auto(7)>
+
L<debhelper(7)>
-This program is a part of debhelper.
+This program is a part of debhelper and its dh_auto package source building suite.
-=head1 AUTHOR
+=head1 AUTHORS
-Joey Hess <joeyh@debian.org>
+ Joey Hess <joeyh@debian.org>
+ Modestas Vainius <modestas@vainius.eu>
=cut