summaryrefslogtreecommitdiff
path: root/dh_auto_clean
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-03-23 21:32:43 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-04-10 16:11:01 -0400
commit776abbb23a899ebba954774c8b3740706a21f72b (patch)
tree8d279923d9da02504af1da0aaaf158558ce73376 /dh_auto_clean
parent51dea74baba625b8d63bbf7e19ad7e069d05ab14 (diff)
Migrates dh_auto_* commands to Dh_Buildsystems.pm
This patch switches dh_auto_* commands to use Dh_Buildsystems.pm module. Most of them became very minimal by design. Documentation has not been updated with new features yet. Signed-off-by: Modestas Vainius <modestas@vainius.eu>
Diffstat (limited to 'dh_auto_clean')
-rwxr-xr-xdh_auto_clean29
1 files changed, 3 insertions, 26 deletions
diff --git a/dh_auto_clean b/dh_auto_clean
index 610155ae..75f3ce48 100755
--- a/dh_auto_clean
+++ b/dh_auto_clean
@@ -7,7 +7,7 @@ dh_auto_clean - automatically cleans up after a build
=cut
use strict;
-use Debian::Debhelper::Dh_Lib;
+use Debian::Debhelper::Dh_Buildsystems;
=head1 SYNOPSIS
@@ -38,31 +38,8 @@ or override the any standard parameters that dh_auto_clean passes.
=cut
-init();
-
-if (-e "Makefile" || -e "makefile" || -e "GNUmakefile") {
- $ENV{MAKE}="make" unless exists $ENV{MAKE};
- foreach my $target (qw{distclean realclean clean}) {
- # Use make -n to check to see if the target would do
- # anything. There's no good way to test if a target exists.
- my $ret=`$ENV{MAKE} -s -n $target 2>/dev/null`;
- chomp $ret;
- if (length $ret) {
- doit($ENV{MAKE}, $target, @{$dh{U_PARAMS}});
- last;
- }
- }
-}
-elsif (-e "setup.py") {
- doit("python", "setup.py", "clean", "-a", @{$dh{U_PARAMS}});
- # The setup.py might import files, leading to python creating pyc
- # files.
- doit('find', '.', '-name', '*.pyc', '-exec', 'rm', '{}', ';');
-}
-elsif (-e "Build.PL" && -e "Build") {
- $ENV{MODULEBUILDRC} = "/dev/null";
- doit("perl", "Build", "--allow_mb_mismatch", 1, "distclean", @{$dh{U_PARAMS}});
-}
+my $manager = new Debian::Debhelper::Dh_Buildsystems;
+$manager->run_dh_auto_tool();
=head1 SEE ALSO