summaryrefslogtreecommitdiff
path: root/dh_auto_configure
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-03-23 21:32:43 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-04-10 16:03:34 -0400
commit93cd875ba2e3ac9eda6adc31b4334d43ef718ea0 (patch)
treefbd83665938169f404fae9ddb5e9cdf456870dd6 /dh_auto_configure
parent877c62f70a904c1f549fbee9f763345bc19c6697 (diff)
Add dpkg_architecture_value and sourcepackage to Dh_Lib
Both these function are taken from dh_auto_configure. I believe they are useful enough to be in Dh_Lib (esp. dpkg_architecture_value()). The patch removes these funtions from dh_auto_configure too. Signed-off-by: Modestas Vainius <modestas@vainius.eu>
Diffstat (limited to 'dh_auto_configure')
-rwxr-xr-xdh_auto_configure23
1 files changed, 0 insertions, 23 deletions
diff --git a/dh_auto_configure b/dh_auto_configure
index 41f6210f..0445c343 100755
--- a/dh_auto_configure
+++ b/dh_auto_configure
@@ -40,29 +40,6 @@ or override the standard parameters that dh_auto_configure passes.
init();
-sub dpkg_architecture_value {
- my $var=shift;
- my $value=`dpkg-architecture -q$var 2>/dev/null` || error("dpkg-architecture failed");
- chomp $value;
- return $value;
-}
-
-sub sourcepackage {
- open (CONTROL, 'debian/control') ||
- error("cannot read debian/control: $!\n");
- while (<CONTROL>) {
- chomp;
- s/\s+$//;
- if (/^Source:\s*(.*)/) {
- close CONTROL;
- return $1;
- }
- }
-
- close CONTROL;
- error("could not find Source: line in control file.");
-}
-
if (-x "configure") {
# Standard set of options for configure.
my @opts;