summaryrefslogtreecommitdiff
path: root/dh_auto_configure
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-04-24 21:05:28 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-04-24 21:05:28 -0400
commit10d72fd2967a0220a3ca3802e3a3593a1f33515c (patch)
tree94a89adfd04189b76f1c43bfda38cd9c71d7a9e1 /dh_auto_configure
parent8290ce0f62ee779b3cb7719776c1431140b91644 (diff)
dh_auto_*: Also support packages using Module::Build.
* dh_auto_*: Also support packages using Module::Build. * dh_auto_*: Fix some calls to setup.py.
Diffstat (limited to 'dh_auto_configure')
-rwxr-xr-xdh_auto_configure12
1 files changed, 8 insertions, 4 deletions
diff --git a/dh_auto_configure b/dh_auto_configure
index 6e56c953..4558403d 100755
--- a/dh_auto_configure
+++ b/dh_auto_configure
@@ -16,10 +16,10 @@ B<dh_auto_configure> [S<I<debhelper options>>] [S<B<--> I<params>>]
=head1 DESCRIPTION
dh_auto_configure is a debhelper program that tries to automatically
-configure a package prior to building. It looks for and runs
-a ./configure script, or Makefile.PL. A standard set of parameters is
-determined and passed to the program that is run. If no program to run
-is found, dh_auto_configure will exit without doing anything.
+configure a package prior to building. It looks for and runs a ./configure
+script, Makefile.PL, or Build.PL. A standard set of parameters is
+determined and passed to the program that is run. If no program to run is
+found, dh_auto_configure will exit without doing anything.
This is intended to work for about 90% of packages. If it doesn't work,
you're encoruaged to skip using dh_auto_configure at all, and just run
@@ -90,6 +90,10 @@ elsif (-e "Makefile.PL") {
$ENV{PERL_MM_USE_DEFAULT}=1;
doit("perl", "Makefile.PL", "INSTALLDIRS=vendor", @{$dh{U_PARAMS}});
}
+elsif (-e "Build.PL") {
+ $ENV{PERL_MM_USE_DEFAULT}=1; # Module::Build can also use this.
+ doit("perl", "Build.PL", "installdirs=vendor", @{$dh{U_PARAMS}});
+}
=head1 SEE ALSO