summaryrefslogtreecommitdiff
path: root/dh_auto_install
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-03-23 21:32:43 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-04-10 16:11:01 -0400
commit776abbb23a899ebba954774c8b3740706a21f72b (patch)
tree8d279923d9da02504af1da0aaaf158558ce73376 /dh_auto_install
parent51dea74baba625b8d63bbf7e19ad7e069d05ab14 (diff)
Migrates dh_auto_* commands to Dh_Buildsystems.pm
This patch switches dh_auto_* commands to use Dh_Buildsystems.pm module. Most of them became very minimal by design. Documentation has not been updated with new features yet. Signed-off-by: Modestas Vainius <modestas@vainius.eu>
Diffstat (limited to 'dh_auto_install')
-rwxr-xr-xdh_auto_install39
1 files changed, 4 insertions, 35 deletions
diff --git a/dh_auto_install b/dh_auto_install
index 264725ca..c115a184 100755
--- a/dh_auto_install
+++ b/dh_auto_install
@@ -8,6 +8,7 @@ dh_auto_install - automatically runs make install or similar
use strict;
use Debian::Debhelper::Dh_Lib;
+use Debian::Debhelper::Dh_Buildsystems;
use Cwd;
=head1 SYNOPSIS
@@ -48,7 +49,8 @@ or override the any standard parameters that dh_auto_install passes.
=cut
-init();
+my $manager = new Debian::Debhelper::Dh_Buildsystems;
+$manager->init_dh_auto_tool();
my $destdir;
my @allpackages=getpackages();
@@ -60,40 +62,7 @@ else {
}
$destdir=cwd()."/".$destdir;
-if (-e "Makefile" || -e "makefile" || -e "GNUmakefile") {
- $ENV{MAKE}="make" unless exists $ENV{MAKE};
- my @params="DESTDIR=$destdir";
-
- # Special case for MakeMaker generated Makefiles.
- if (-e "Makefile" &&
- system('grep -q "generated automatically by MakeMaker" Makefile') == 0) {
- push @params, "PREFIX=/usr";
- }
-
- foreach my $target (qw{install}) {
- # Use make -n to check to see if the target would do
- # anything. There's no good way to test if a target exists.
- my $ret=`$ENV{MAKE} -s -n $target 2>/dev/null`;
- chomp $ret;
- if (length $ret) {
- doit($ENV{MAKE}, $target,
- @params,
- @{$dh{U_PARAMS}});
- last;
- }
- }
-}
-elsif (-e "setup.py") {
- doit("python", "setup.py", "install",
- "--root=$destdir",
- "--no-compile", "-O0",
- @{$dh{U_PARAMS}});
-}
-elsif (-e "Build.PL" && -e "Build") {
- $ENV{MODULEBUILDRC} = "/dev/null";
- doit("perl", "Build", "install", "destdir=$destdir",
- "create_packlist=0", @{$dh{U_PARAMS}});
-}
+$manager->run_dh_auto_tool($destdir);
=head1 SEE ALSO