summaryrefslogtreecommitdiff
path: root/dh_auto_install
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-06-18 02:11:45 +0300
committerModestas Vainius <modestas@vainius.eu>2009-06-18 02:11:45 +0300
commit962a2e10c930e3504ea1c0327be2fdf70d53023e (patch)
tree26196a25203b03818d92dd5a8ec49d2e13111675 /dh_auto_install
parent91928482af09c4ca1092f124921d0f47613c17ba (diff)
Update dh_auto documentation.
* dh_auto.pod -> dh_auto.7 - contains general information about dh_auto, its features, build systems supported by default (the latter is injected by man/dh_auto_pod script from Debian/Debhelper/Buildsystem/*.pm PODs via placeholders (#PLACEHOLDER#)) * POD in Debian/Debhelper/Buildsystem/*.pm -> dh_auto_<buildsystem>.7 - build system specific information. * dh_auto_* -> dh_auto_*.1 - relatively shorty description of the specific dh_auto_* program and build system specific info for that step injected from Debian/Debhelper/Buildsystem/*.pm with man/dh_auto_pod script. * man/dh_auto_pod $step - generates full dh_auto_$step POD (replaces placeholders). * man/dh_auto_pod - generates full dh_auto.pod (replaces placeholders). Signed-off-by: Modestas Vainius <modestas@vainius.eu>
Diffstat (limited to 'dh_auto_install')
-rwxr-xr-xdh_auto_install37
1 files changed, 22 insertions, 15 deletions
diff --git a/dh_auto_install b/dh_auto_install
index db2c6e90..5c772245 100755
--- a/dh_auto_install
+++ b/dh_auto_install
@@ -2,7 +2,7 @@
=head1 NAME
-dh_auto_install - automatically runs make install or similar
+dh_auto_install - install built files into the temporary directory under debian/
=cut
@@ -13,14 +13,15 @@ use Cwd;
=head1 SYNOPSIS
-B<dh_auto_install> [S<I<debhelper options>>] [S<B<--> I<params>>]
+B<dh_auto_install> [S<I<debhelper options>>] [S<I<dh_auto options>>] [S<B<--> I<params>>]
=head1 DESCRIPTION
-dh_auto_install is a debhelper program that tries to automatically install
-built files. If there's a Makefile and it contains a "install" target,
-then this is done by running make (or MAKE, if the environment variable is
-set). If there is a setup.py or Build.PL, it is used.
+dh_auto_install is a debhelper program that is responsible for the I<install>
+step of the L<dh_auto(7)> building process. dh_auto_install tries to run
+original package installation routine to install built files into the proper
+places of the file system hierarchy recreated under the (temporary) directory
+in debian/.
The files are installed into debian/<package>/ if there is only one binary
package. In the multiple binary package case, the files are instead
@@ -28,13 +29,10 @@ installed into debian/tmp/, and should be moved from there to the
appropriate package build directory using L<dh_install(1)> or
L<dh_movefiles(1)>.
-DESTDIR is used to tell make where to install the files.
-If the Makefile was generated by MakeMaker from a Makefile.PL, it will
-automatically set PREFIX=/usr too, since such Makefiles need that.
+If dh_auto_install does not meet your needs or does not work, it is safe to
+skip/override it entirely and just run C<make install> or the like manually.
-This is intended to work for about 90% of packages. If it doesn't work, or
-tries to use the wrong install target, you're encouraged to skip using
-dh_auto_install at all, and just run make install manually.
+#DH_AUTO SHARED OPTIONS#
=head1 OPTIONS
@@ -47,6 +45,11 @@ or override the any standard parameters that dh_auto_install passes.
=back
+=head1 SUPPORTED BUILD SYSTEMS
+
+#SUPPORTED BUILD SYSTEMS INTRO#
+#SUPPORTED BUILD SYSTEMS LIST#
+
=cut
buildsystems_init();
@@ -65,12 +68,16 @@ buildsystems_do("install", $destdir);
=head1 SEE ALSO
+L<dh_auto(7)>
+
L<debhelper(7)>
-This program is a part of debhelper.
+This program is a part of debhelper and its dh_auto package source building
+suite.
-=head1 AUTHOR
+=head1 AUTHORS
-Joey Hess <joeyh@debian.org>
+ Joey Hess <joeyh@debian.org>
+ Modestas Vainius <modestas@vainius.eu>
=cut