summaryrefslogtreecommitdiff
path: root/dh_auto_install
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-04-24 21:05:28 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-04-24 21:05:28 -0400
commit10d72fd2967a0220a3ca3802e3a3593a1f33515c (patch)
tree94a89adfd04189b76f1c43bfda38cd9c71d7a9e1 /dh_auto_install
parent8290ce0f62ee779b3cb7719776c1431140b91644 (diff)
dh_auto_*: Also support packages using Module::Build.
* dh_auto_*: Also support packages using Module::Build. * dh_auto_*: Fix some calls to setup.py.
Diffstat (limited to 'dh_auto_install')
-rwxr-xr-xdh_auto_install9
1 files changed, 6 insertions, 3 deletions
diff --git a/dh_auto_install b/dh_auto_install
index be052e21..8e6e8934 100755
--- a/dh_auto_install
+++ b/dh_auto_install
@@ -19,7 +19,7 @@ B<dh_auto_install> [S<I<debhelper options>>] [S<B<--> I<params>>]
dh_auto_install is a debhelper program that tries to automatically install
built files. If there's a Makefile and it contains a "install" target,
then this is done by running make (or MAKE, if the environment variable is
-set). If there is a setup.py, it is used.
+set). If there is a setup.py or Build.PL, it is used.
The files are installed into debian/<package>/ if there is only one binary
package to act on. In the multiple binary package case, the files are
@@ -80,12 +80,15 @@ if (-e "Makefile" || -e "makefile" || -e "GNUmakefile") {
}
}
elsif (-e "setup.py") {
- doit("python setup.py", "install",
+ doit("python", "setup.py", "install",
"--root=$destdir",
"--no-compile", "-O0",
@{$dh{U_PARAMS}});
}
-
+elsif (-e "Build.PL" && -e "Build") {
+ doit("perl", "Build", "install", "destdir=$destdir",
+ "create_packlist=0", @{$dh{U_PARAMS}});
+}
=head1 SEE ALSO