summaryrefslogtreecommitdiff
path: root/dh_auto_install
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-06-25 12:28:28 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-06-25 12:28:28 -0400
commit60b19d214d43e11e090f939b330d897f297369c5 (patch)
treeb42b64f0ebf7cddaadd38f95dd50892b4ee9c0d7 /dh_auto_install
parentde199fa0eed6ec684caab8194819a83c1b3b958b (diff)
dh_auto_install: Rather than looking at the number of binary packages being acted on, look at the total number of binary packages in the source package when deciding whether to install to debian/package or debian/tmp. This avoids inconsistencies when building mixed arch all+any packages using the binary-indep and binary-arch targets. Closes: #487938
Diffstat (limited to 'dh_auto_install')
-rwxr-xr-xdh_auto_install7
1 files changed, 4 insertions, 3 deletions
diff --git a/dh_auto_install b/dh_auto_install
index 78fba170..2c8c7f6b 100755
--- a/dh_auto_install
+++ b/dh_auto_install
@@ -22,8 +22,8 @@ then this is done by running make (or MAKE, if the environment variable is
set). If there is a setup.py or Build.PL, it is used.
The files are installed into debian/<package>/ if there is only one binary
-package to act on. In the multiple binary package case, the files are
-instead installed into debian/tmp/, and should be moved from there to the
+package. In the multiple binary package case, the files are instead
+installed into debian/tmp/, and should be moved from there to the
appropriate package build directory using L<dh_install(1)> or
L<dh_movefiles(1)>.
@@ -51,7 +51,8 @@ or override the any standard parameters that dh_auto_clean passes.
init();
my $destdir;
-if (@{$dh{DOPACKAGES}} > 1) {
+my @allpackages=getpackages();
+if (@allpackages > 1) {
$destdir="debian/tmp";
}
else {