summaryrefslogtreecommitdiff
path: root/dh_auto_test
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-04-23 14:37:34 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-04-23 14:37:34 -0400
commitb3a6127c13c1226aa5b6c36b6c71dd3d74193c6d (patch)
tree07fe22385963ce3c54603f59cf17f2bd8a8ee090 /dh_auto_test
parente7706c28cecffccb52f2f1e6a30a141f23fbfcf5 (diff)
dh_auto_clean: New program, automates running make clean (or distclean, or realclean), or using setup.py to clean up.
Diffstat (limited to 'dh_auto_test')
-rwxr-xr-xdh_auto_test13
1 files changed, 9 insertions, 4 deletions
diff --git a/dh_auto_test b/dh_auto_test
index 74a80e8c..cf6e58a2 100755
--- a/dh_auto_test
+++ b/dh_auto_test
@@ -42,11 +42,16 @@ or override the any standard parameters that dh_auto_test passes.
init();
if (-e "Makefile" || -e "makefile" || -e "GNUmakefile") {
+ $ENV{MAKE}="make" unless exists $ENV{MAKE};
foreach my $target (qw{test check}) {
- my $ret=system("make --question $target >/dev/null 2>&1");
- if ($ret == 0) {
- doit(exists $ENV{MAKE} ? $ENV{MAKE} : "make",
- $target, @{$dh{U_PARAMS}});
+ # Make --question returns false if the target is
+ # up-to-date. But we still want to run the target in this
+ # case. So ceck if a target exists by seeing if make outputs
+ # "Making target".
+ my $ret=`LANG=C $ENV{MAKE} --question $target 2>/dev/null`;
+ chomp $ret;
+ if ($ret =~ /^Making \Q$target\E/m) {
+ doit($ENV{MAKE}, $target, @{$dh{U_PARAMS}});
last;
}
}